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Getting Started with SIwave
Conventions Used in this Guide
Please take a moment to review how instructions and other useful infor-
mation are presented in this guide. 
•    Procedures are presented as numbered lists. A single bullet indicates 

that the procedure has only one step.
•    Bold type is used for the following:

- Keyboard entries that should be typed in their entirety exactly as 
shown. For example, “copy file1” means to type the word copy, to 
type a space, and then to type file1.

- On-screen prompts and messages, names of options and text boxes, 
and menu commands. 

- Labeled keys on the computer keyboard. For example, “Press 
Enter” means to press the key labeled Enter.

•    Menu commands are often separated by the “>” symbol. For exam-
ple, “Click Draw>Cylinder”.

•    Italic type is used for the following:
- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be typed in place 
of the words in italics. For example, “copy file name” means to 
type the word copy, to type a space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indicate that you 
should press the keys at the same time. For example, “Press 
Shift+F1” means to press the Shift key and the F1 key at the same 
time.

Alternate methods or 
tips are listed in the left 
margin in blue italic 
text. 
 iii



Getting Started with SIwave
Getting Help

Ansoft Technical Support
To contact Ansoft technical support staff in your geographical area, 
please log on to the Ansoft website, http://www.ansoft.com/ots/otsLo-
gin.cfm. You will find phone numbers and e-mail addresses for the tech-
nical support staff. You may also contact your Ansoft account manager to 
obtain this information.
All Ansoft software files are ASCII text and can be sent conveniently by e-
mail. When reporting difficulties, it is extremely helpful to include very 
specific information about what steps were taken or what stages the 
simulation reached. This allows more rapid and effective debugging.
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1
Introduction
This Getting Started Guide is written for SIwave beginners as well as 
experienced users who would like to quickly familiarize themselves 
with the capabilities of SIwave. This guide leads you step-by-step 
through creating, solving, and analyzing the results of simulating nets 
and planes on a PCB.
By following the steps in this guide, you will learn how to perform the 
following tasks in SIwave:
D Draw a geometric model.
D Specify solution settings for a design. 
D Validate a design's setup. 
D Run an SIwave simulation.
D Create 2D plots of the results.

Estimated time to 
complete this guide:
60 minutes.
1-1



Getting Started with SIwave
The PCB Model
The PCB model consists of two single-ended transmission lines on an 
irregularly shaped, 4-layer PCB. Layers 1 and 4 are signal layers, and 
layers 2 and 3 are planes for power and ground.
The PCB model is shown below. 

You will analyze the performance of the nets by injecting signals into the 
Top-L and Bot-L terminals. These nets are transmission lines that begin on 
layer 1 and transition to layer 4. You will examine reflected signals at the 
same terminals, and transmitted signals at terminals Top-R and Bot-R.
To analyze the planes, you will calculate the impedance between the 
planes at the terminal Plane in the bottom-right corner of the PCB when a 
power supply, modeled as a 1-ohm resistor, is connected at the upper-left 
corner of the PCB.

Plane
1-2 Introduction
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Expected Results
Ideally, the output signals should represent the input signals. To achieve 
this, the signal path should be treated like a transmission line whose 
characteristic impedance is matched to that of the driver and the receiver. 
Since a via is located on the net, you can expect to see a discontinuity.
For the plane impedance, ideally, you would see the impedance of the 
power supply at the terminal where the IC is drawing current. If the imped-
ance is too high, an adequate voltage cannot be maintained on the IC at all 
times.
The implied assumption with the desired behavior is that there is no dis-
continuity in the signal return path, and, equivalently, that the potential 
variation between planes is small over the frequency range of interest. 
Whether this assumption is reasonable depends on the geometry of the 
PCB.
To determine if the results agree with these expectations, you will examine 
the results in both the time domain and the frequency domain, and the 
impedance of the planes versus frequency. You will also examine the 
resonant modes of the planes to understand the observed behavior.
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2 Setting Up the Design
In this chapter you will complete the following tasks:
D Create and save a new project.
D Set up the layer stack.
D Set up the pad stack.
D Set the drawing units for the design.

Estimated time to 
complete this chapter:
15 minutes.
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Open SIwave and Save a New Project
A project file contains information about the geometry, PCB layer stack-up, 
pad stack, via construction, board materials, and any discrete compo-
nents. 
To start the exercise, launch SIwave and then create a new project file:
1  Double-click the SIwave icon on your desktop to launch SIwave.
2  Click File>Save.

The Save As dialog box appears.
3  Locate and double-click the folder in which you want to save the 

project, such as C:\Ansoft\SIwave\Project.
4  Type PCB-Example.siw in the File name box, and then click Save.
The project is saved in the folder you selected to the file name 
PCB-Example.siw.
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Set Up the Layer Stack
You will need to supply the information about the PCB geometry and mate-
rials in the layer stack up.
Set up the layer stack for the PCB:
1  Click Edit>Layer Stack.

The Layer Stack-up Editor dialog box appears.
2  Change the name of the layer to Signal-Top. 
3  Leave the default values for the remaining options.
4  Repeat steps through 2 for Metal-2, Metal-3, and Metal-4 so that they 

are called Ground, Power, and Signal-Bottom, respectively.
5  Click Edit>Layer Stack to view the new names of the layers in the 

Layer Stack-up Editor window. 

In the Properties work-
space, select Metal-1. 
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Set Up the Pad Stack
In addition to the layer stack, you need to specify information about the 
pads and vias. 

You can set the drill hole for a via by creating or editing a circular pad on 
the dielectric layer between the two metal layers that the via connects. 
Therefore, a single via can have different shaft radii depending on the lay-
ers that it passes through.
You will now set up the pad stacks for the vias that will be used.
1  Click Edit>Padstacks.

The Padstack Editor window appears. Padstack names are listed on 
the top left, next to the cross-sectional view.

2  Select Signal-Top from the Layer list, and verify the following:

• Radius under Pad Properties is 0.25mm.

• Shape under Antipad Properties is set to None.

• Shape under Thermal Relief Pad Properties is set to None.
3  Select the other padstacks and layers, and verify that the values 

correspond to the table below: 

Padstack Layer Material
Pad 
Rad. 
(mm)

Anti-
pad 
Rad.

Thermal 
Relief 
Pad 
Rad. 
(mm)

VIA_M1_M2 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-1
Signal-Bottom

Copper 0.25
0.15
0.25
None
None
None
None

None
None
None
None
None
None
None

None
None
None
None
None
None
None
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VIA_M1_M3 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-3
Signal-Bottom

Copper 0.25
0.15
None
0.15
0.25
None
None

None
None
0.35
None
None
None
None

None
None
None
None
None
None
None

VIA_M1_M4 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-3
Signal-Bottom

Copper 0.25
0.15
None
0.15
None
0.15
0.25

None
None
0.35
None
0.35
None
None

None
None
None
None
None
None
None

VIA_M2_M3 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-3
Signal-Bottom

Copper None
None
0.25
0.15
0.25
None
None

None
None
None
None
None
None
None

None
None
None
None
None
None
None

Padstack Layer Material
Pad 
Rad. 
(mm)

Anti-
pad 
Rad.

Thermal 
Relief 
Pad 
Rad. 
(mm)
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4  Click OK to close the Padstack Editor window. 

VIA_M2_M4 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-3
Signal-Bottom

Copper None
None
0.25
0.15
None
0.15
0.25

None
None
None
None
0.35
None
None

None
None
None
None
None
None
None

VIA_M3_M4 Signal-Top
Dielectric-1
Ground
Dielectric-2
Power
Dielectric-3
Signal-Bottom

Copper None
None
None
None
0.25
0.15
0.25

None
None
None
None
None
None
None

None
None
None
None
None
None
None

Padstack Layer Material
Pad 
Rad. 
(mm)

Anti-
pad 
Rad.

Thermal 
Relief 
Pad 
Rad. 
(mm)
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3 Creating the Model
In this chapter you will complete the following tasks:
D Draw the ground plane.
D Copy the ground plane to the power plane.
D Create the signal nets.
D Add ports to the signal nets.
D Add a resistor to model the power supply connection to the plane.
D Add a port to the planes to measure the impedance of the IC 

connection point.

Estimated time to 
complete this chapter:
15 minutes.
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Create the PCB Layout
The PCB project consists of a four-layer, T-shaped board. Represent the 
plane on Ground by drawing two rectangles. Then, copy the plane to 
Power.
Next, draw signal traces that begin on the top layer and transition to the 
bottom layer through via holes, and add ports to each terminal.
Finally, add pads on the top layer that connect to the planes through the 
via holes so that you can simulate the impedance of the planes.

Draw the Ground Plane
You will now draw the T-shaped planes.
1  Click the Layers workspace.
2  Click Ground. 
3  Click Draw>Rectangle.
4  Click at (-30, 20) to indicate the starting point.
5  Click at (30, 0) to indicate the end point.
6  Click Draw>Drawing Mode>Merge.
7  Draw a second rectangle at (-10, 0) and (10, -20). 

8  Click Draw>Rectangle again to exit the Drawing Mode.
9  Click the Nets workspace.
10 Select NET-1 by clicking on the box next to it.
11 Click Edit>Nets>Change Name.

The Enter New Net Name window appears. 
12 Enter Ground in the Net Name box, and click OK.
13 Click File>Save.

Copy the Ground Plane to the Power Plane
You will now copy the ground plane to the power plane.
1  Click the Nets workspace, and select Ground.
2  Click Edit>Copy.
3  Click the Layers workspace.
4  Select Power in the list of layers.
5  Click Edit>Paste.

Note The two rectangles are automatically merged into a single T-shaped 
plane.
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6  Move the cursor to position the object so that it overlaps the object on 
the Ground layer.

7  Click the Nets workspace.
8  Select Ground-1 by clicking on the box next to it..
9  Click Edit>Nets>Change Name.

The Enter New Net Name window appears. 
10 Enter Power in the Net Name box, and click OK.
11 Click File>Save.
12 Click the Layers tab. Your project should look like the following figure:
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Draw First Signal Net
You will now draw the first of the two signal traces.
1  Click Draw>Set Trace Width.

The Set Trace Width window appears.
2  Type 0.2 in the Trace Width box, and click OK. 

This provides a microstrip line with a characteristic impedance of 
approximately 50 ohms on the 0.1 mm thick FR-4 layer.

3  Click the Layers workspace, and select Signal-Top.
4  Click Draw>Trace.
5  Click at (-30, 12) to indicate the starting point of the trace on the top 

layer.
6  Double-click at (10, 12) to indicate the end point.
7  Click Draw>Via.
8  Select VIA_M1_M4 from the pull-down list on the Via toolbar.
9  Click at (10, 12).
10 Select Signal-Bottom.
11 Click Draw>Trace.
12 Click at (10, 12) to set the starting point.
13 Double-click at (30, 12) to indicate the end point.
14 Click the Nets tab, and select NET-1.
15 Click Edit>Nets>Change Name.

The Enter New Net Name window appears. 
16 Type Signal-Top in the Net Name box, and click OK.
17 Click File>Save.
3-4 Creating the Model
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Your project should look like the following figure:

The background 
color was modified 
to white by clicking 
View>Modify 
Attributes>Gradient 
Background.
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Draw the Second Signal Net
You will now draw the second signal traces. 
1  Click Draw>Trace if you do not have it already selected from the 

previous step.
1  Click the Layers workspace, and select Signal-Top.
2  Click at (-30, 8) to indicate the starting point of the trace on the top 

layer.
3  Double-click at (0, 8) to indicate the end point.
4  Click Draw>Via.
5  Select VIA_M1_M4 from the pull-down list on the Via toolbar.
6  Click at (0, 8).
7  Select Signal-Bottom.
8  Click Draw>Trace.
9  Click at (0, 8) to set the starting point.
10 Double-click at (30, 8) to indicate the end point.
11 Click the Nets workspace.
12 Select NET-1.
13 Click Edit>Nets>Change Name.

The Enter New Net Name window appears. 
14 Type Signal-Bottom in the Net Name box, and click OK.
15 Click File>Save.

Add Ports to Signal Nets
You will now add ports to the two signal nets so they can be simulated.
1  Click Circuit Element>Port.
2  Click at (-30, 12) to define the positive terminal for the port.
3  Click at (-30, 12) to define the reference terminal for the port.

The Select layers for port terminals window appears.
4  Select Signal-Top for the positive terminal and Ground for the negative 

terminal, and click OK.
The Port Properties window appears.

5  Type Top-L in the Name box, and leave the default value for Reference 
Impedance. 

6  Click OK.

You can also change 
the net name by right-
clicking NET-1, and 
then choosing Edit Net 
Name.
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7  Repeat steps 2 through 6 so that you have four ports as described in 
the table below:

8  Click Circuit Elements>Port again to exit the Drawing Mode.
9  Click File>Save.
10 Click View>Circuit Elements>Element Names>All on.

Location Layer
Port 

Name
Reference 
Impedance

Positive 
Terminal

Negative 
Terminal

X Y X Y Positive Negative

-30 12 -30 12 Signal-
Top

Ground Top-L 50

30 12 30 12 Signal-
Bottom

Power Top-R 50

-30 8 -30 8 Signal-
Top

Ground Bot-L 50

30 8 30 8 Signal-
Bottom

Power Bot-R 50

If required, you can 
edit port values by 
clicking Edit>Circuit 
Element Parameters.
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Your project should look like the following figure:
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Add the Power-Supply Connection
You will now add a structure to model a power supply connected between 
the power and ground planes. This structure will consist of two vias con-
necting to the ground and power planes and extending above the board. 
Very small planes will be attached to the tops of the vias, and the power 
supply will be connected to those planes. For the high-frequency simula-
tion, the power supply will be represented as a simple one-ohm resistor.
1  Click View>Zoom In.
2  Click on a point slightly above and to the left of the upper-left corner of 

the board.
3  Click on a second point slightly inside the board. The grid spacing 

adapts to the new view.
4  Click Draw>Via.
5  Select VIA_M1_M2 from the Via toolbar.
6  Click at (-29, 19).
7  Select VIA_M1_M3 from the Via toolbar.
8  Click at (-29, 18).
9  Click the Layers workspace, and select Signal-Top.
10 Click Draw>Rectangle.
11 Click at (-29.2, 19.2) to start a rectangle.
12 Click at (-28.0, 18.8) to complete the rectangle.
13 Click at (-29.2, 18.2) to start another rectangle.
14 Click at (-28.0, 17.8) to complete the second rectangle.
15 Click Circuit Elements>Resistor.
16 Click at (-29.2, 19.0) and at (-29.2, 18.0) to place the resistor.

The Select layers for resistor terminals window appears.
17 Select Signal-Top for both the positive and negative terminals, and 

click OK.
The Set Resistor Parameters window appears.

18 Type 1 in the Resistance box, and leave the default value for the other 
options. 

19 Click OK.
20 Click Circuit Elements>Resistor to exit this option.
21 Select View>Fit All.
22 Click File>Save.

You may want to zoom 
in, by clicking 
View>Zoom In.
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Add the IC Connection
You will now add a port at the IC location to examine the plane impedance 
“seen” by the IC. This port will connect to the vias, which, in turn connect to 
the planes. 
1  Click View>Zoom In.
2  Click on a point slightly below and to the right of the lower-right corner 

of the board.
3  Click on a second point slightly inside the board. The grid spacing 

adapts to the new view.
4  Click Draw>Via.
5  Select VIA_M1_M2 from the Via toolbar.
6  Click at (9, -19) to create the ground connection.
7  Select VIA_M1_M3 from the Via toolbar.
8  Click at (9, -18) to create the power connection.
9  Click Circuit Elements>Port.
10 Click at (9, -19.0) and at (9, -18.0) to place the port, snapping to the 

vias.
The Select layers for port terminals window appears.

11 Select Signal-Top for both the positive and negative terminals, and 
click OK.
The Port Properties window appears.

12 Type Plane in the Name box, and leave the default value for the 
reference impedance.

13 Click OK.
14 Click Circuit Elements>Port to exit this option.
15 Select View>Fit All.
16 Click File>Save.
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Your project should look like the following figure:
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4 Generating the Solutions 
In this chapter you will complete the following tasks:
D Generate the S-parameters for the signal nets.
D Generate the TDR and TDT responses for the signal nets.
D Display the impedance of the planes on a log-log plot.

Estimated time to 
complete this chapter:
15 minutes.
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Solve for the Performance of the PCB
Now you will analyze the performance of two aspects of the PCB. The first 
is the signal-integrity characteristics of the signal nets. You will examine 
these in the frequency domain using s-parameters, and in the time domain 
by looking at the TDR and TDT responses.
Next, review the power-integrity characteristics of the planes by examining 
the impedance between the power and ground planes versus frequency.

Analyze Performance of the Signals Traces
You will now analyze the performance of the signal nets.
1  Click Simulation>Compute S-, Y-, Z-parameters.

The Compute SYZ-parameters window appears.
2  Specify the following values:

3  Click OK.
SIwave simulates the model with various values in the specified range. 
After the solution is generated, the results are displayed in the Results 
workspace.

4  Double-click the sweep. 
The SYZ Parameter Plot Generation dialog appears.

5  Leave the default values for all options, and click Create Plot.

Start Frequency 5e6

Stop Frequency 5e9

Number of Points 1000
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SIwave Reporter is launched, and the S-parameter plot is generated.
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Generate the TDR Plot
The TDR (time-domain reflectometry) plot shows the impedances encoun-
tered by the signal as it travels along the line. These plots help determine 
the impedance that the signal encounters along its path.
1  In the SIwave Reporter, click SIwave>Results>Create Standard 

Report>Rectangular Plot.
The Report window appears.

2  From the Domain pull-down list on the left, select Time.
3  Click the TDR Options button.

The TDR Options window appears. 
Do the following:

a. Click the Step radio button, and then type 35ps in the Rise Time 
box.

b. Type 1e-8 in the Maximum Plot Time box.

c. Type 1e-11 in the Delta Time box.

d. Leave the default values for all other options, and click OK to close 
this window, and return to the Report window.

4  In the Category list, select TDR Impedance.
5  In the Quantity list, do the following:

a. Click TDRZ(Bot-L).

b. Press Ctrl, and click TDRZ(Top-L).
6  In the Function list, verify that mag is selected.
7  Click New Report.

A trace represents a line connecting data points on the plot.
8  Click Close. 
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A graph showing the TDR response for the traces is generated. The 
plot is listed as XY Plot1 under Results in the project tree.

The plot shows that the transmission line has an impedance near 
46 ohms. Due to the limited frequency sweep, the resolution is not 
good enough to distinguish the via. The steady-state impedance is 
approximately 51 ohms, as the power supply and the vias add to the 
50 ohm termination.
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Generate the TDT Plot
The TDT (time-domain transmission) plot shows how a voltage step with a 
specified rise time is affected by the impedance discontinuities it has 
encountered as it traveled the length of the transmission line.
1  Click SIwave>Results>Create Standard Report>Rectangular Plot.

The Report window appears.
2  From the Domain pull-down list on the left, select Time.
3  Click the TDR Options button.

The TDR Options window appears. Do the following:

a. Type 35ps in the Rise Time box.

b. Type 1e-8 in the Maximum Plot Time box.

c. Type 1e-11 in the Delta Time box.

d. Leave the default values for all other options, and click OK to close 
the window.

4  In the Category list, verify that S Parameter is selected
5  In the Quantity list, do the following:

a. Click S(Bot-L,Bot-R).

b. Press Ctrl, and click S(Top-L,Top-R).
6  In the Function list, verify that re is selected.
7  Click New Report.

A trace represents a line connecting data points on the plot.
8  Click Close. 
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A graph showing the TDT response for the traces is generated.

The observed delay time matches the expected delay time for a 60 mm 
long line on FR4_epoxy.
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Analyze Performance of the Planes
You will now analyze the performance of the planes.
1  Click SIwave>Results>Create Standard Report>Rectangular Plot.

The Report window appears.
2  In the Category list, click Z Parameter.
3  In the Quantity list, click Z(Plane,Plane).
4  In the Function list, click mag.
5  Click New Report.
6  Click Close. 

The impedance of the planes versus frequency is displayed.
7  Double-click the y-axis.

The Contrast Properties window appears.
8  Click the Scaling tab.
9  Click the Log radio button on the right side of the window, and then 

click OK.
10 Repeat steps 8 and 9 for the x-axis.
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A log-log impedance plot of the planes is displayed.

At a low frequency, the one-ohm resistance of the power supply is 
modeled.

11 Click File>Save to save this plot. 
12 Click File>Exit to close the Ansoft SIwave Reporter.
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5 Analyzing the Results 
In this chapter you will complete the following tasks:
D Calculate the resonant modes of the PCB.
D Compare the results of the resonant mode calculation with the s-

parameters calculation.

Estimated time to 
complete this chapter:
15 minutes.
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Analyze the Behavior of the PCB
In this section, you will examine the results obtained from the simulation 
more closely to see how they match the performance you expected.

Characteristics of the Two Signal Nets
You will compare the performance of the signal nets. Looking at S21 for 
Signal-Top and Signal-Bottom shows that their performance significantly 
differs as frequency increases. This seems surprising since they are 
located relatively close to each other, with the only difference being the 
position of the via along the trace. Even so, the nulls in the frequency 
domain responses are different. There are frequencies where both nets 
exhibit nulls, although the depths of the nulls are different (i.e. 2.626 hz). 
The path of the return current for each net is not obvious. Ideally, the return 
current should follow a path very close to the signal path. Since the planes 
are solid, the only location where there might be a discontinuity in the 
return path is near the via where the return path changes from the ground 
plane to the power plane. A difference in the potential between the two 
planes indicates that the current in the return path encounters a disconti-
nuity due to a high impedance.
At low frequencies, the voltage between the planes should be very small 
since they are connected together with a low-value resistor. However, as 
the frequency increases, and the dimensions of the plane approach a 
significant fraction of a wavelength, you can set up resonant modes. 
SIwave can calculate the relative voltage between the planes for each of 
these modes.

Calculate Resonant Modes
You will now calculate the resonant modes of the PCB to determine if 
these are responsible for the difference in performance of the two signal 
nets.
1  Click Simulation>Compute Resonant Modes.

The Resonant Mode Solution Options window appears.
2  Type 10 in the # of Modes to Compute box.
3  Leave the default values for all other options, and click OK.
5-2 Analyzing the Results



Getting Started with SIwave
After the simulation finishes, the results are listed under the Results 
workspace. The resonant modes are located at nearly the same fre-
quencies as the nulls in the S21 responses for the two nets. 

4  Click Results>Resonant Mode. Then, select the simulation name and 
click View Results. 
The Resonant Modes dialog box appears.

5  In the Plot voltage difference between planes on box:

a. Select Ground from the first pull-down list.

b. Select Power from the second pull-down list. 

c. Click Compute.
After the simulation finishes, your desktop should look like the 
following:
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6  Click the Phase Animation button in the Resonant Mode Results 
window.
The Phase Animation window appears.

7  Click the Generate Frames button.
The frames are generated and displayed in the window.

8  Click the icon to continuously loop through the simulations. To 
stop, click the button.

9  See the different views of the model in the desktop:

• Click View>Zoom In.

• Click View>Rotate.

• Click View>Pan.
10 Click Close in the Phase Animation window.
11 Click Close in the Resonant Modes window.

Compare S21 Responses
You will now analyze the performance of the signal nets, and then gener-
ate the S21 plot.
1  Click Results>SYZ. Then, select the simulation name and click Plot 

Magnitude/Phase.
The SYZ Parameter Plot Generation dialog box appears.

2  Select Bot-L, Bot-R.
3  Select Top-L,Top-R.
4  Leave the default values for all other options, and click Create Plot.
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SIwave Reporter is launched. A graph showing the S21 response for 
the traces is generated. 
 

5  Click Close to close the SYZ Parameter Plot Generation dialog box.
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Close the Project and Exit SIwave
Congratulations! You have successfully completed Getting Started with 
SIwave: A PCB Model! You may close the project and exit the software.

1. Click File>Save.

2. Click File>Exit.
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